Back to overview
Degraded

Registration is downgraded

Sep 17 at 07:04pm CEST
Affected services
Colossyan Website

Resolved
Sep 17 at 08:16pm CEST

We resolved the issue. Registrations are back to normal.

Created
Sep 17 at 07:04pm CEST

We have received an increased number of reports about issues related to registration. The issue is being investigated.